Actions

EmSys

OpenOCD Troubleshooting: Unable to Fetch Product Description

From EdWiki

Revision as of 04:47, 7 March 2012 by Jshankar (Talk | contribs) (1 revision: Importing from edes32)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

You run OpenOCD on Ubuntu and it cannot communicate with your FTDI drivers. If you use an OpenOCD build compiled with the libftdi driver library, it exits on startup after printing this error:

Error: unable to open ftdi device: unable to fetch product description

OpenOCD requires superuser privileges to communicate with your drivers. For information on running OpenOCD as root on Ubuntu, see OpenOCD and Permissions. If you have access to your system's root password and wish to allow other users to run penOCD without sudo, see Accessing Devices without Sudo.